Back to overview
Maintenance

Update Version 2.11.17

Jan 01 at 05:20am EST  –  Jan 01 at 07:00am EST
Affected services
Platform
Hosting & Inference
Storage
Payment
Email

Resolved
Jan 01 at 05:20am EST

Hi Team/Users, we're conducting planned to run major update version 2.11.17. During this window, you may experience intermittent access to all features. Thanks for your understanding!